Back to overview
Resolved
Underlying technical infrastructure maintenance
Jun 22, 2026 at 7:30am UTC
Affected services
Pico
Leadflows
Resolved
Jun 22, 2026 at 10:00am UTC
All services are fully operational without delays again
Affected services
Created
Jun 22, 2026 at 7:30am UTC
Our Cloud provider is updating their technical infrastructure which may lead to short disruptions of service. Users may experience longer load times or slight hiccups but should not be disrupted finishing their leadflows.
Affected services